= =之前就听说5.0出来了,一直懒得弄,报错一堆,不同ruby版本的报错还不一样,很难受……….

环境:

1
2
3
ubuntu 17.10
win的话,有空再填
ruby 2.3.6p384 (2017-12-14) [x86_64-linux-gnu] (这个地方版本自己用rvm切换)

直接上命令,懒得截图报错了.

1
2
3
4
git clone https://github.com/rapid7/metasploit-framework.git
cd metasploit-framework
sudo apt-get install libpq-dev ruby-dev libpcap-dev zlib1g-dev liblzma-dev libsqlite3-dev
bundle install

ln -s 你值得拥有

emmmmmm